Resolved
This incident is now resolved, and all services are working as expected 🎉
Monitoring
We are currently monitoring recovery from a brief period of increased error rates and latencies on the Maze app.
Investigating
We are currently investigating an issue causing longer than usual load times in the Maze app. Our Engineers are actively working to resolve this. We will provide updates as more information becomes available.