Maze

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Observers are unable to join moderated studies
Resolved·Partial outage

The issue is now resolved. Observers should be able to join and access moderated interview studies as expected.

Wed, Apr 22, 2026, 04:48 PM
(1 month ago)
·
Affected components
Apr 22, 2026, 03:28 PM
04:48 PM
Interview Studies
Updates

Resolved

The issue is now resolved. Observers should be able to join and access moderated interview studies as expected.

Wed, Apr 22, 2026, 04:48 PM

Monitoring

We've implemented a fix and observers should now be able to join moderated interview studies as expected. We'll continue to the monitor the issue.

Wed, Apr 22, 2026, 04:10 PM(37 minutes earlier)

Investigating

We're currently experiencing issues with observers unable to join moderated interview studies. Observers are met with a loading screen and the video stream does not start. We'll provide more updates as soon as possible.

Wed, Apr 22, 2026, 03:28 PM(41 minutes earlier)