Resolved
The issue where Clips failed to load and displayed the error message “Unable to load video” has been resolved by our Engineering Team.
We sincerely appreciate your patience and understanding while we addressed this matter.
Investigating
Clips are currently failing to load, displaying the error message “Unable to load video” instead of playing as expected. The issue is impacting multiple mazes, and our Engineering team is actively investigating.
We’re working to identify the root cause and restore normal playback as quickly as possible.