Maze

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Issues placing participant panel orders
Resolved·Full outage

This issue is now resolved. Panel orders can be submitted and created as expected.

Mon, Feb 23, 2026, 09:37 PM
(3 months ago)
·
Affected components
Feb 23, 2026, 07:45 PM
09:37 PM
Updates

Resolved

This issue is now resolved. Panel orders can be submitted and created as expected.

Mon, Feb 23, 2026, 09:37 PM

Monitoring

A fix has been implemented and we are currently monitoring. Panel orders should now be processed successfully. Please re-submit any orders that might have failed during the incident.

Mon, Feb 23, 2026, 09:15 PM(21 minutes earlier)

Investigating

We're currently observing issues with panel orders not being created within our provider, Prolific. We are investigating the root cause. Thank you for your patience while we work towards a resolution.

Mon, Feb 23, 2026, 07:45 PM(1 hour earlier)