Maze

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Search failing due to provider outage
Resolved

Search in Maze should now be operational again. Thanks for your patience while we worked towards a fix.

Thu, Feb 12, 2026, 04:27 PM
(4 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

Search in Maze should now be operational again. Thanks for your patience while we worked towards a fix.

Thu, Feb 12, 2026, 04:27 PM

Identified

Search in Maze is currently failing due to a provider outage. We are investigating the issue and working to determine a solution.

Thu, Feb 12, 2026, 03:06 PM(1 hour earlier)