Resolved
The CDN configuration has been fixed and the system is fully operational
Investigating
We’re currently experiencing an issue where the PDF file in the Legal block is not visible due to a “Failed to upload” error message. Our team is actively investigating the root cause and working on a fix.
We’ll provide an update as soon as the issue is resolved or we have more details to share.