Participant results are not loading
Resolved·Partial outage

This issue is now resolved. Results should be loading as expected on the participants page. Thank you for your patience while we worked towards a fix.

Thu, Sep 25, 2025, 03:12 PM
(3 weeks ago)
·
Affected components
app.maze.co
Updates

Resolved

This issue is now resolved. Results should be loading as expected on the participants page. Thank you for your patience while we worked towards a fix.

Thu, Sep 25, 2025, 03:12 PM

Monitoring

We've now implemented a fix and results should be loading as expected on the participants page. We'll continue to monitor the services in the meantime.

Thu, Sep 25, 2025, 01:51 PM(1 hour earlier)

Investigating

We are currently facing issues with loading the participant results. Our Engineering Team is diligently working to resolve this as quickly as possible. We appreciate your patience!

Thu, Sep 25, 2025, 12:33 PM(1 hour earlier)