Issues joining Maze conferencing
Resolved·Degraded performance

We resolved the issue and users should now be able to join Maze Conferencing interviews without any problems. Apologies for the trouble caused!

Thu, Jul 10, 2025, 11:18 PM
(1 month ago)
·
Affected components
Interview Studies
Updates

Resolved

We resolved the issue and users should now be able to join Maze Conferencing interviews without any problems. Apologies for the trouble caused!

Thu, Jul 10, 2025, 11:18 PM

Identified

Users may experiencing problems joining Maze conferencing when joining from within the Maze app. A fix is in the process of being rolled out

Thu, Jul 10, 2025, 10:50 PM(28 minutes earlier)