Disruption on Maze Participate App on Android
Resolved·Degraded performance

The issue has now been resolved. Thank you for your patience as we worked towards a resolution, and our apologies for any disruption this may have caused.

Mon, Jul 7, 2025, 12:12 PM
(1 month ago)
·
Affected components
Updates

Resolved

The issue has now been resolved. Thank you for your patience as we worked towards a resolution, and our apologies for any disruption this may have caused.

Mon, Jul 7, 2025, 12:12 PM

Identified

We've identified an issue where participants are unable to access the Maze Participate App on Android. We are working to resolve this as quickly as possible. Our apologies for any disruption this has caused.

Fri, Jul 4, 2025, 12:33 PM(2 days earlier)