Some Mazes are temporary inaccessible
Resolved

The issue affecting access to some mazes has been resolved. All systems are now fully operational. We appreciate your understanding and apologize for any inconvenience caused!

Tue, May 27, 2025, 09:39 AM
(2 weeks ago)
·
Affected components

No components marked as affected

Updates

Resolved

The issue affecting access to some mazes has been resolved. All systems are now fully operational. We appreciate your understanding and apologize for any inconvenience caused!

Tue, May 27, 2025, 09:39 AM

Investigating

We're currently experiencing an issue causing some mazes to be inaccessible. Our Engineering Team is diligently investigating the matter and is committed to restoring full functionality as swiftly as possible.Thank you for your patience!

Tue, May 27, 2025, 08:51 AM(48 minutes earlier)