Some users are unable to log in to https://app.maze.co using their Maze credentials
Resolved·Partial outage

We have released a fix for the issue, and users should now be able to log in without any problems. We apologize for the inconvenience caused!

Fri, May 23, 2025, 05:42 AM
(3 weeks ago)
·
Affected components
Updates

Resolved

We have released a fix for the issue, and users should now be able to log in without any problems. We apologize for the inconvenience caused!

Fri, May 23, 2025, 05:42 AM

Investigating

We are currently investigating an issue where some users are unable to log in to https://app.maze.co using their Maze credentials

Fri, May 23, 2025, 05:06 AM(35 minutes earlier)