Some Mazes are temporary inaccessible
Resolved·Partial outage

The issue affecting access to some mazes has been resolved. All systems are now fully operational. We appreciate your understanding and apologize for any inconvenience caused.

Tue, May 6, 2025, 10:08 AM
(1 month ago)
·
Affected components
app.maze.co
Updates

Resolved

The issue affecting access to some mazes has been resolved. All systems are now fully operational. We appreciate your understanding and apologize for any inconvenience caused.

Tue, May 6, 2025, 10:08 AM

Investigating

We're currently experiencing an issue causing some mazes to be inaccessible. Our Engineering Team is actively investigating and working to restore full functionality as quickly as possible. Thank you for your patience!

Tue, May 6, 2025, 10:05 AM