Issues created hired panel participant orders
Resolved·Full outage

This issue is now resolved. You should be able to submit panel participant orders as expected.

Wed, Apr 30, 2025, 02:11 PM
(1 month ago)
·
Affected components
Updates

Resolved

This issue is now resolved. You should be able to submit panel participant orders as expected.

Wed, Apr 30, 2025, 02:11 PM

Investigating

We're currently experiencing issues with submitting hired panel participant orders. Our apologies for the inconvenience this has caused.

Wed, Apr 30, 2025, 01:39 PM(31 minutes earlier)