Intermittent application errors when accessing maze for some users
Resolved·Partial outage

This issue is resolved, and users should no longer encounter an application error when accessing Maze. Our apologies for the disruption this has caused.

Wed, Apr 16, 2025, 04:58 PM
(2 months ago)
·
Affected components
app.maze.co
Updates

Resolved

This issue is resolved, and users should no longer encounter an application error when accessing Maze. Our apologies for the disruption this has caused.

Wed, Apr 16, 2025, 04:58 PM

Identified

We've identified the root cause of the issue and we're implementing a fix.

Wed, Apr 16, 2025, 04:30 PM(27 minutes earlier)

Investigating

We're currently experiencing issues that impacts some users where they encounter an application error. We are investigating this issue and working towards a fix. Our apologies for the disruption this has caused.

Wed, Apr 16, 2025, 04:15 PM(15 minutes earlier)