Issues accessing the Maze app and testing links
Resolved·Full outage

This issue is resolved. The Maze application and testing links should now load as expected. Thank you for your patience as we worked towards a resolution.

Wed, Mar 26, 2025, 04:20 PM
(1 week ago)
·
Affected components
app.maze.co
Updates

Resolved

This issue is resolved. The Maze application and testing links should now load as expected. Thank you for your patience as we worked towards a resolution.

Wed, Mar 26, 2025, 04:20 PM

Investigating

We're currently investigating an issue where the Maze app and testing links are unavailable. Our apologies for the disruption this has caused.

Wed, Mar 26, 2025, 04:07 PM(12 minutes earlier)