Panel orders are not able to be successfully placed
Resolved·Full outage

The issue where Panel orders were not able to be successfully placed and where a device type was not able to be selected has been resolved. You should now be able to place a panel order successfully without encountering any errors. Thank you for your patience while we worked to get this resolved.

Mon, Feb 17, 2025, 04:00 PM
(1 month ago)
·
Affected components
Updates

Resolved

The issue where Panel orders were not able to be successfully placed and where a device type was not able to be selected has been resolved. You should now be able to place a panel order successfully without encountering any errors. Thank you for your patience while we worked to get this resolved.

Mon, Feb 17, 2025, 04:00 PM

Identified

We've identified the cause of the issue and are working on a fix as quickly as possible. Thank you for your continued patience.

Mon, Feb 17, 2025, 02:37 PM(1 hour earlier)

Investigating

We're currently experiencing issues with placing hired panel participant orders. We are investigating the cause and working towards a fix. Our apologies for the disruption this has caused.

Mon, Feb 17, 2025, 01:34 PM(1 hour earlier)