Some Prolific hired tester orders are not being completed
Resolved·Degraded performance

This issue is now resolved. Thank you for your patience as we worked towards a resolution.

Mon, Feb 10, 2025, 04:33 PM
(1 month ago)
·
Affected components
Updates

Resolved

This issue is now resolved. Thank you for your patience as we worked towards a resolution.

Mon, Feb 10, 2025, 04:33 PM

Investigating

We're currently investigating an issue where some Prolific hired tester orders are not completing. Our apologies for the disruption this has caused.

Mon, Feb 10, 2025, 04:24 PM