Resolved
The issue where some Maze Reports were displaying a "This is a private report page" and enters you into a log in loop has been resolved. You should now be able to load your Reports without issue. Thank you for your patience.
Identified
Currently, some Maze Reports are displaying a "This is a private report. Log in to your Maze account to view it." page and enters you into a log in loop. We apologize for the inconvenience and are working to resolve this as quickly as possible.