Unable to place panel orders with a credit card
Resolved
Partial outage

The issue has been resolved. You should now be able to place a hired tester panel order with a credit card. Thank you for your patience.

Wed, Oct 16, 2024, 12:46 PM
2 months ago
Affected components
Updates

Resolved

The issue has been resolved. You should now be able to place a hired tester panel order with a credit card. Thank you for your patience.

Wed, Oct 16, 2024, 12:46 PM
31m earlier...

Investigating

We're currently investigating an issue with placing panel orders with a credit card. Our apologies for the inconvenience this has caused. We are working to restore the service as quickly as possible and will continue to provide updates.

Wed, Oct 16, 2024, 12:14 PM